Problem pasting clipboard content in new image (v1.2-beta10)


#1

Hi, in the last beta something strange happens when doing this:

1 - create a new canvas of 64 x 64, for example
2 - select an area (16x16 for example) of that part and copy it
3 - create a new canvas, this new canvas will have the size of the copied area automatically.
4 - paste the selection on the new canvas.

The selection is sticking out of the canvas, out of place.
In the previous beta it was sticking correctly inside the canvas.


#2

Hi @SynthED, it’s a regression. This bug appeared because we’ve fixed #1447. You can see in that discussion what was solved. It’s a tricky situation here (something was solved, but something else was broken).

There is no easy or straight forward way to fix this one. A possible idea: If we are pasting the clipboard into a new image (not in the source image from where the clipboard was copied), we should limit the pasted image to the canvas bounds (old behavior). If the clipboard is pasted in the source image, we use the new behavior.


#3

Ok thanks for the info, it is not very annoying but I think it is something that should be addressed although I do not consider it an urgent error.


#4

This bug is fixed on Aseprite v1.2-beta11, I’ll close this topic (please create a new topic in case that the bug is still present or reappears).


closed #5