Right Click to reverse colors not working when shading with custom brush type

While using the spray tool in shading mode you can left-click to go towards the left side of your colors. Likewise, you can right-click towards the right side. After (maybe?) hitting a key, for some reason I can not right-click to go right when using a custom brush type

I’ve tried creating new custom brushes, new documents, and restoring default keybinds, and haven’t quite found a way to fix this

An example of what Im referring to is the bottom section of the aseprite shading doc:

Here is also a picture of my current screen, though without a video, its a little hard to show exactly what I’m doing:

Aseprite v1.3.7 - Steam

try making the custom brush black, i think its getting confused since it has a color by default

Thanks for the suggestions but it didn’t end up working

Hi @Mooshee, would you mind to share with us your user.aseprite-brushes file? it’s located in the preferences folder.

Of course. However, I am new to this website and it is telling me that I can only send certain file types, of which the “user.aseprite-brushes” file isn’t supported. How should I send you this file?

Oh sorry about that, you can send it to my mail david@igara.com :+1:

hey its been awhile, were you ever able to check out the file you requested?

Sorry @Mooshee, your mail ended up in the spam. I’ll try to review it tomorrow or Monday. We’re in the middle of a family emergency this week.

@Mooshee thanks for the file! I’ve just tested this a little and something might be working wrong. At least I’m having problems to use the shading tool with Left click after selecting one of your custom brushes, but then after pressing X key a couple of times (when you press X key the shades of colors is reversed) it start working with both mouse buttons.

I’ll test this a little more next week but I’d like to know if pressing X key a couple of times after selecting a brush “fixes” your problem at least temporarily.

Hey, thanks for the response.
I hope all ends up well with your family,

I loaded up Aseprite today to test what you said and to my surprise, everything suddenly works now without any change. I had spent an hour or two every day testing it out but for some reason at least for today, it works fine. Unless you had pushed out a fix that I didn’t notice this has been a very strange issue that appeared randomly and disappeared just the same

As for what you said, I’ve had that same issue where after changing my brush, only the right click works. My workaround for the longest time was to just reselect the colors I wanted and suddenly the left and right click worked fine, though it’s great to know I can just hit ‘x’ twice and that also fixes it as it is much faster. (Though funny enough, by now its muscle memory, and trying to test the x key fix was impossible because I couldn’t stop myself from reflecting the colors lol)

That being said I’m pretty sure what you are describing was a different problem to what I was having. With the previous issue, hitting x or reselecting my colors didn’t fix it, making shading toward the right completely impossible.