Rotsprite doesn't work when scaling manually


Aseprite v1.2.39-x64 seems to have stopped using Rotsprite algorythm when scaling manually (it still works if you scale the whole sprite from “Sprite > Sprite size”). I’m not sure if this happens also with some previous Aseprite versions, since I don’t always use rotsprite for everything.

Here’s a video showing how it works now and how it should have worked:

Ok, it seems it’s not a bug, but the side effect of a new implemented option (Force Rotsprite even for right/straight angles) being unchecked by default.

I checked it and now it works, the name kind of confused me, sorry about the inconveniences.

1 Like

This still seems like a bug, so I wouldn’t mark that as the solution just yet. That checkbox is meant to prevent distortions when you rotate your work in 90 degree increments, but one shouldn’t have to change that checkbox every time they want to scale some artwork without rotating it. Scaling should still enable RotSprite, I think, even if there’s no rotation.


Yeah, I think you are right.

Also, even if it was intentional (I was trying to upscale to 200%), Scaling and Rotation using Rotsprite should be probably separated into two different checkboxes.

I’ll unmark the post as a solution then.

It’s not possible to make them separate settings since a transformation can consist of both scaling and rotation at once. However, I think it’s a reasonable assumption that of someone has enabled RotSprite and are scaling, they want it regardless of the rotation value.