Scripts Not Appearing

Hi, for some reason the scripts that I add to my folder aren’t appearing after I restart Aseprite. Here are the steps I take. Please let me know if I’m doing something wrong.

  1. Go to script on GitHub
  2. Click on “Raw”
  3. Right-click and click “Save As”
  4. Save it as is on my desktop.
  5. Open Aseprite
  6. File > Scripts > Open Scripts Folder
  7. Copy/paste or drag/drop script from Desktop to “scripts” folder
  8. Close Aseprite
  9. Open Aseprite
  10. Create a new file (I’ve done this without creating a new one too)
  11. File > Scripts
  12. It shows “Open Scripts Folder”, “Rescan Scripts Folders”, and “Debugger”
  13. When I click on “Open Scripts Folder” the .lua file is in the folder

I’m not sure how to actually get Aseprite to run the script. It’s in the correct folder, but the open isn’t there on Aseprite to run it. I’ve tried multiple scripts too, some old, some new.

Any help would greatly be appreciated!

Also, I’m running Aseprite v1.2.32-x64

1 Like

Hi @Rockah0lic,

Hmm… Just a guess: in steps 3-4, right click saving a file in browser may append a .txt extension. For example, the file name would be myScript.lua.txt. With Hide extensions for known file types enabled in folders, the files may appear to have a .lua extension when they in fact don’t.

Is the result different when you download and unpack a .zip of the whole repo by clicking on the green Code button in the upper right corner on Github?



That was it! Everything works perfectly now. Thank you so much!