Selecting and Painting with Mask (SOLVED)

Hey Everyone! Something funny is happening and it’s tripping me up.

I’ve got a newborn, and in order to draw while I’m holding her, I set some things up to be as effective as possible one-handed. I set right-click to “pick foreground color” so I wouldn’t need the eye-dropper tool, and instead of using the eraser tool, I’d select the mask with right click, and then “paint” with it, which worked like erasing. Suddenly, today, I can no longer paint with the mask.

I’m set to RGB mode, and I’m using Simple Ink.

I can still right click to select foreground color, but I can’t select the mask, and if I select it manually, I can’t “paint” with it to erase.

Any ideas? Your help is much appreciated!

Hard to say. Do you think you could print screen the entire program while you have a file where this doesn’t work open?

I’m not sure how to print screen the entire program.

All you need to do is press the print screen button on your keyboard, then you can simply paste (Ctrl+V) in the text box here on the community site and it should upload it. However you can also make a new file in Aseprite and paste it there if there’s anything you want to crop out first, then simply select it all and copy it, then paste it here.

Thanks! Does this give you the information that you need?

Hmm, no I can’t really see anything that would cause the problem. In this case “Mask” is selected as background color, but I assume you just haven’t picked it as foreground color here. For me it still works fine to right click to pick mask anywhere on the background when right click is set to Pick Foreground color, so as long as the setting hasn’t reverted for some reason, and you’re on the correct layer, it should work.

Something else you could check is if you’ve changed the settings on the eyedropper (pick the eyedropper or hold alt) in the top context bar to not include Alpha, If it’s not set to something with +Alpha it can’t select mask. But even if that was the case you should still be able to draw with mask if you pick it manually.


I can’t really think of any other reasons.

1 Like

That fixed it!! I had to change the eyedropper settings to Color+Alpha. Oh wow, this is a huge help - thanks!

1 Like

Glad it worked. :+1: