[Solved] Error saving file (macOS Big Sur 11.1)

Hey gang

I can’t for the life or me find a way to save or export my files. I get the following error:
Screen Shot 2021-01-13 at 8.19.29 pm

I have given Aseprite full disk access:
Screen Shot 2021-01-13 at 8.19.59 pm

It doesn’t matter where I try it won’t save. I’m running Aseprite from the Itch client.


Hi @Cam, never saw something similar, but I’m worried about the “running Aseprite from the Itch client” part, did you try to run Aseprite directly? I’m not sure but I think the itch app does somekind of sandboxing, lowering the permissions of the app (but I’m not 100% sure)

1 Like

Thanks, Dave. You were right, I ran the Aseprite app outside of the client and everything works as expected. I tried giving the Itch client full disk access but that still didn’t fix it so there’s definitely something strange going on with the Itch client as you suggested.

TBH the only reason I even ran it through the Itch client in the first place was because of the lack of update feature in the standalone version (and I have no idea where my key is anyway!).

I’ve created a shortcut to Aseprite and placed it in the Applications folder so it turns up in Spotlight and the Applications folder in the Dock. For updates I’ll have to persist with Itch though.

Thanks again!