Style refresh button not found

Hey there! Seems that this error shows up:

When CTRL+SHIFT+S (or just CTRL+S if its a new sprite) and in the text editor when i pick a custom font… idk if it happens with any other GUI. Thanks for helping!

1 Like

Update: Seems to be a bug in the new version, it does not happens with older versions but when i re-install the new one it comes back

Note: I haven’t developed themes before and so I cannot guarantee that the following instructions are entirely useful or correct.

I checked the theme.xml files for dark and default. It’s interesting that I only found the refresh button code on the default theme:

        <style id="refresh_button" extends="mini_button">
            <icon part="arrow_circle_cw" />
            <icon part="arrow_circle_cw_selected" state="selected" />

However, I have not encountered the issues you’ve described while I’ve worked in dark theme. Perhaps you could replace your themes folder data with mine and see if that fixes it? (IDK why the themes would not update automatically, but I suspect something fishy is happening there).

https://drive.google.com/drive/folders/1ufftOOV6aHdEmnsbPzZ_nsqLemoKRHuh?usp=sharing

click edit → preferences


click Theme → click one of the Themes → Open Folder

You can try replacing the theme data there with my theme data which is working. Download the whole aseprite-theme folder from my google drive and extract it. I hope this helps.

Thank you so much! The problem was that the theme was made for an older ase version… i fixed it!

1 Like

Hi @LIUKRAST, this issue should be fixed in v1.3-beta16 (it was a temporal problem in v1.3-beta15)