Unusable with Luna Display & Astropad Studio

Hi, I use the Steam version of Aseprite (v1.3-beta21). So far, I have had no problems with it, until I switched to a very unusual tablet setup, I use an iPad Air with Apple Pencil and I use it with my Windows 11 laptop via Luna Display + Astropad Studio combo.
The problem I’m describing here is difficulty and inconsistency when interacting with most of the UI elements. When trying to click elements, such as checkboxes in options, buttons such as Save, OK, Apply, Cancel, etc., it often does not click as it would normally with a dedicated PC tablet such as the ones from Wacom. I have tried multiple options using Windows Ink and Wintab32, but most of the time it simply doesn’t work normally. However, other software, such as Photoshop, work flawlessly with my kind of setup.
If there are any questions on the issue, feel free to ask. Thanks for the support.

Knowing that other software works as expected with your setup does suggest that Aseprite should work, too. I have a similar setup, except with a MacBook (which Luna & Astro were originally designed for), and I can’t think of a time when I ran into anything similar. That said, I’ve thought of some things you should try (if you haven’t already):

  1. try a different build of Aseprite (non-beta, to start)
  2. experiment with the screen scaling and UI elements scaling options in Aseprite’s General preferences.
  3. experiment with other Aseprite settings, perhaps particularly those in Experimental (maybe the render engine?)

Ah, interesting! Nice to see another Luna & Astropad user. It seems that switching to version 1.2.40 immediately fixed the issue, whereas the screen and UI scaling and experimental settings did not affect anything significantly.
It seems that 1.3-beta21 uses some kind of different method of rendering that can’t be changed and thus, causes the issue I experienced. I’m not sure if Microsoft Surface users might’ve experienced a similar issue, since Luna & Astropad sort of emulates that functionality, whereas Wacom uses completely different methods and only uses Windows’ built-in touch & pen functionality as a fallback when drivers are misbehaving.
Thanks for your help, and I hope this issue gets fixed. Shame I can’t work on tilesets for the time being.