Very low performance after installing 1.3

I am noticing a huge performance loss after installing 1.3.
Both drawing on canvas and zooming in and out seems to be really slow(or slower than it was with previous versions). It gets slower the more I zoom in so it’s really annoying when working on smaller details.

I tried enabling the simple crosshair but it did nothing, I disabled my themes and all of that jazz but nothing seems to change the behaviour.

The rest of the app seems to be working properly and I have no issues at all with UI, adding and deleting layers/frames works as before.

Hi @chroma_dave, does this happen on every sprite you edit? (and even without editing sprites?) or does happen in specific sprites?

Would you mind to share with us a sprite where it happens at (or if you confirm us that it happens with any sprite, e.g. an empty sprite 32x32 it’s just enough)?

Do you have a tablet/stylus? what model/brand? driver version?


Thank you for a quick response.

The issue was happening even on empty canvas at 8x8px.
I fiddled around with it and figured a solution, although I am not sure what the issue was.

I tried portable 1.3 and it worked perfectly so I figured there was something wrong with my configuration or extensions, so I went into %AppData%/Aseprite/ and selectively deleted stuff from there.
What seemed to fix the issue was completely deleting the aseprite.cfg file and scripts folder so I think I was using some script which significantly slowed the app (although I don’t understand why I also needed to delete the aseprite.cfg)

Anyways, I think this was the issue but at least this thread might help someone in the future. Thank you again!