Wintab option no longer working


Since Windows Ink is completely unusable, I really enjoyed the option to turn on Wintab in Aseprite. It gave me pressure sensitivity without all the annoyances that came with Having Windows Ink enabled.

Unfortunately, that option randomly stopped working for me. No matter if I enable “Wintab” or “Wintab (direct packet processing)”, It just keeps using Wndows Ink, even if the checkbox is still checked. (indicated by that little flashing circle i get every time the pen touches the tablet, and the Interface showing which Shortcut key I’m pressing like Shift or Alt)

If I disable WIndows Ink in the Tablet Settings (Huion), I don’t have get the annoying circle etc, but pen pressure sensitivity is fully lost.

Was there a change to this functionality?

Hi @Fey, actually the only change we did was set Windows Pointer API (Windows ink) as the default one. But changing to Wintab should still work.

Anyway, it might happen that if Aseprite crashes because a buggy Wintab driver (there is a long history of Wintab crashes from third-party vendors) Aseprite will switch automatically to the Windows Pointer API just to avoid a future crashes.

Some details here: Aseprite causes miscellaneous crashes to programs around it · Issue #2785 · aseprite/aseprite · GitHub

For example we’ve received 90 crash reports so far from 31 users related to crashes produced by third-party errors from Wintab that we cannot fix (this without counting all the user support/and previous crash report with received directly from users via email):

Hi dacap,

those crashes were happening for a while, but i just kept switching back to WinTab for as long as it worked. Because working with Windows Ink is near impossible, so I was okay with the occasional crash.

But now switching literally doesn’t do anything. Just nothing. I still get all the Windows Ink Problems (The flashing circle, the Alt/Shift etc. indicator) and so on. I’ve tried both options, there’s no change. (See video below)

Is there a way to do a clean WinTab reinstall? Or something like that?


1 Like

Just in case, does the Huion settings have a similar option as the “Use Windows ink” one in Wacom configuration? Because with Wintab that circle effect should be gone (but it depends if the Wintab/Huion driver disable it/doesn’t use Windows ink).

Anyway I tried to disable the circle effect of pen & touch and I wasn’t able to, at least I tested on Windows 11 and it looks like the effect was gone for most apps but on Aseprite it was still present (it’s really strange because it should be a system wide option). So this is a bug.

As a side note, seeing your video, just enabling Wintab should work as it was working in previous versions, so re-enabling Wintab by default wouldn’t make a difference between this version and the previous one. Probably something else has changed in your computer (like the Huion driver or an internal Windows Ink setting).

Yes, it does, and it used to work just fine with the circle disappearing when I selected WinTab (besides the occasional crash). The problem is, If i turn it off in the driver, I lose pen pressure completely.

If we could get rid of that circle in Aseprite that would be ideal as that’s the most inconvenient part.

I didn’t change anything about my huion driver or Wintab, asides from attempting to reinstall WinTab after the issue started (that didn’t work, unfortunately) So I’m at my wit’s end. :cold_sweat: I’ll try to plug in a wacom though and see if that changes anything.

OK, please keep us updated in case you try a Wacom. I’ll try to investigate about this next week, why the circle effect is still visible when it’s disabled on the Windows Ink settings.