Add new layer broken

v1.3 beta6 on win10

i use shift+n to add new layer. expected behaviour: new layer is added above the current active layer.

how it works now:
A) - if the layer (or one of its cels) is selected, new layer is added above it

B) - when you draw on canvas the focus is lost and the layer is only darkened, then shift+n will add new layer on the top of the whole stack. after you use other tool, for example marquee tool, the new layer will be added above the current layer as expected.

C) - same as B, however instead of selecting layer or using another tool keep adding new layers. this will happen:
the topmost active layer will be the newest one while previously added layer will be shifted to the position where it should have been in the first place.

tried the light theme, does the same thing.

strangely enough this is not happening when new layer is added via layer -> new layer.

1 Like

Thanks @Olga_Galvanova, I was able to reproduce this, I’ve just created a new issue related to this: Fix Shift+N behavior in v1.3-beta · Issue #2957 · aseprite/aseprite · GitHub

1 Like