Aseprite v1.2.34.1 and v1.3-beta13

Today we’re releasing Aseprite v1.2.31 and v1.3-beta8 with several bug fixing, macOS M1 chip support, and improved Linux support (e.g. drop files inside the window & several fixes to use multiple windows).

Just released a patch for the regressions:

Aseprite v1.2.31

  • Windows: Include aseprite-thumbnailer on Aseprite installer by default
  • Windows: Added new icon for main window when Windows DPI=150% #3034
  • Windows: Fixed possible crashes at exit if some events are still queued when we close the app #3055
  • macOS: New Universal binary (including Intel and M1 code in the same .app bundle) #2451
  • macOS: Fixed glitch moving mouse #3032 t/11558
  • Linux: Added support to drag-and-drop files from the File Manager to Aseprite #1410
  • Lua: Fixed error iterating layers named with numbers #3045
  • Lua: Fixed clipping when drawing a cel image into other image #3054
  • Lua: Added filenamechange event to Sprite.events (thanks to @lampysprites)
  • Lua: Dialog:modify() supports combobox options (thanks to @Omar-Abdul-Aziz)
  • Added automatic crash reporting on Windows & macOS if the user wants to share them
  • Fixed other bugs #2030 #2893 #3069 #3073 #3123

Aseprite v1.2.32

  • Fixed regression clicking same spot with selection tools to deselect t/12491
  • Improved the detection of a single click for styluses/pens to deselect

Aseprite v1.2.33

  • Fixed random crashes in despeckle/median filter #2903
  • Fixed random crashes after moving the selection/pixels #3161
  • Fixed radial gradient when the gradient vector is close to (0,0) #3126
  • Don’t show “Reset Scale” notification/red flag when there is enough workarea available on the desktop
  • Lua: Added a warning message deleting objects that are not part of the sprite #3135
  • Lua: Generate onclick event when we reorder/click a Dialog:shades with { mode="sort" } #3081
  • Lua: Added Color{ index } and fixed Color.index to return an integer instead of a number #3159

Aseprite v1.2.34

  • Added options to change the downsampling algorithm #3183
  • Windows: Use Windows pointer API and disable wintab32 by default #2785
  • Fixed crash pasting 24bpp images from the clipboard #2979
  • Fixed several problems handling slices in animations #3122

Aseprite v1.2.34.1

  • Fixed crash opening palettes popup #3189

Aseprite v1.3-beta8

  • Fixed Shift+N to add new layers in the correct place t/10760 #2957
  • Linux: Fixed several bugs with some Window Managers #2777
  • Lua: Fixed Dialog.bounds values when a dialog is closed on multiple windows UI #3018
  • Fixed other bugs #3052 #3082

Aseprite v1.3-beta9

  • Fixed popup menu size when multiple windows UI is disabled t/12497

Aseprite v1.3-beta10

  • Fixed crash closing a menu box with scrollbars #3132
  • Fixed Frame/Zoom fields visibility on status bar when opening the first file t/12488/11

Aseprite v1.3-beta11

  • Include fixes from v1.2.33

Aseprite v1.3-beta13

  • Added options to simulate mouse wheel using key shortcut + drag mouse #3195
  • Fixed simple click with “Pixel perfect” + contour tool t/13149
  • Fixed clipped Auto Guides when scrolling the canvas #2994
  • Fixed painting with transparent color, opacity 255, Indexed color mode, in Alpha Compositing to behave as Simple Ink #3047
  • Lua: Fixed crash using app.useTool() when the selection is floating/being transformed #2933

Remember to check the Aseprite v1.3 announcement just in case you missed it, and how to update Aseprite if you need help.

5 Likes

New update crashes upon start up when using on steam with Mac OS. Can you look into this please?

Hi @Waters, other user reported that but we cannot reproduce it, what version of macOS are you using? Could you please try to run the following command in the Terminal?

~/Library/Application\ Support/Steam/steamapps/common/Aseprite/Aseprite.app/Contents/MacOS/aseprite

What does it say?

Yea sure! I’m currently using “Mac OS Mojave” “Version 10.14.6”

And this is what appears within the terminal

" ~/Library/Application\ Support/Steam/steamapps/common/Aseprite/Aseprite.app/Contents/MacOS/aseprite
dyld: lazy symbol binding failed: Symbol not found: _objc_opt_new
Referenced from: /Users/harleywaters/Library/Application Support/Steam/steamapps/common/Aseprite/Aseprite.app/Contents/MacOS/aseprite (which was built for Mac OS X 12.0)
Expected in: /usr/lib/libobjc.A.dylib

dyld: Symbol not found: _objc_opt_new
Referenced from: /Users/harleywaters/Library/Application Support/Steam/steamapps/common/Aseprite/Aseprite.app/Contents/MacOS/aseprite (which was built for Mac OS X 12.0)
Expected in: /usr/lib/libobjc.A.dylib

Abort trap: 6
Harleys-MacBook-Pro:~ harleywaters$ "

Thanks for the information, it looks like Mojave doesn’t support this “universal” binary, I think I’ll release the Intel version of the binary on Steam, that might fix this problem. I’ll need your help later to check if that is true.

No problem! Can I send you my personal email? Just to ensure I respond quicker

Contact me at support@aseprite.org with a link to your comment, I’ll take care of the ticket.

The macOS 10.14 issue should be solved right now in Steam (updated dmg file in HB, itch and Gumroad too).

Just released a patch for the regressions:

Aseprite v1.2.32

  • Fixed regression clicking same spot with selection tools to deselect t/12491
  • Improved the detection of a single click for styluses/pens to deselect

Aseprite v1.3-beta9

  • Fixed popup menu size when multiple windows UI is disabled t/12497
3 Likes

Click-to-deselect works nicely even with a stylus, thank you!

Edit: And I see the right-click menus look good again even with multiple window UI enabled.

1 Like

Hello there, I’ve just found an error after I updated to the v1.3-beta9 via Steam. When I run Aseprite, the frame and Zoom indicators located usually in the bottom right of the screen aren’t visible. This doesn’t happen with the v1.2.32. I have to enter and exit Advance mode with Ctrl+F to get the indicators visible again.

(My OS is Windows 10)

2 Likes

Hi guys! I’m running Aseprite 1.2.32 on a M1 Mac Book Pro (BigSur), Steam edition.
I usually run the app from /Users/me/Library/Application Support/Steam/steamapps/common/Aseprite/Aseprite.app but now it runs the arm-64 version with the New Aseprite v1.2.32 available! notification button activated.
If I run the app from Steam, it runs the -x64 (which I desume is the M1 version) and the notification button is gone.
There is a way to start the M1 version directly from the app, bypassing Steam?
Thank you in advance!

P.S. By the way, i’m in love with Aseprite.

1 Like

Hi @pixi_bit! Actually the M1 version is the -arm64 one, and the -x64 is the Intel one. From what you said it looks like Steam executes the -x64 version from the Universal binary, it’s quite strange because Steam should just execute the binary (and not looking inside the Universal binary).

1 Like

You’re right! I’m going to fix it (there will be a new v1.3-beta10 today with other critical fix).

1 Like

Hey @dacap thanks for the instant reply! Well, this sound great for my issue.
If I can be useful, feel free to ask me any kind of test you need, I’m glad to help.

Thank you for macOS M1 chip support!!

1 Like

Hello! I’m pretty new to Asperite, and I keep seeing the New Asperite V1.2.32 is available button, but when i click on it, it brings me right here. Not exactly sure how to update to the current version, if I even should. A reply back would be awesome! Loving Asperite, by the way. Not great yet, but pixel art has now become a hobby / passion of mine and I’m so happy to have an application as good as this.

1 Like

hi rhetoric, you have to update from the website you’ve got the aseprite in the first place. that would be humble bundle, gumroad, itch.io or steam.

1 Like

Hello, thank you for the awesome work on Aseprite!
I have a small issue, even though I’ve updated Aseprite (via Humble Bundle), I still get the “New Aseprite” notification. I cannot find a way to dismiss it. Please see the picture below.

I am on an M1 macOS Monterey 12.3. I have tried updating again.

4 Likes

Hi @umutseven92, thanks for your kind words. About that bug, it’s highly probable that it’s related to a bug in our server. I’ll fix this ASAP and maybe in a day you will not see that message again (no need for update).

1 Like