Aseprite 1.2.5/1.2.6 OSX 10.9.5 scrambled animation


#1

hi, i have a problem with aseprite on OSX 10.9.5,
as soon as i start to animate different frames the sequence gets played back randomly, not sequentially.
i think it was ok with previous versions…

thanks!


#2

I have the same issue, also on OX 10.9.5


#3

Can you please check if the duration of all frames is the same or if there is some frame with duration = 0? (You can see the duration of each frame from Frame > Frame Properties menu option or pressing P key).

I don’t know yet if this is a performance problem or if it’s an issue where some frames might end with duration = 0 depending on a specific sequence of commands (the most probable thing is that it’s a performance issue).


#4

Please contact me at support@aseprite.org if you want to give a try to a special alpha version to check if you can reproduce this issue.


#5

i just tested again with 1.2.6, when drawing 3 frames (duplicating the first 2 times w/ alt+D and changing 2nd and 3d) it gets already scrambled. i don’t even touch or change frame duration or properties… looking at properties frame duration is default 100 each frame.

if you want i can send an animated GIF showing the problem


#6

I am having this problem too.
Frame to frame works fine. Only play does this crazy dance of random frames.
OS 10.10.5
Where can I find older versions of version 1? All I can find is version 0, which seems to only crash.
Otherwise I have a product I bought for animating that I can’t use for animating.


#7

Oh, hey, found an interesting thing while messing around. I was able to reproduce the problem while rapidly pressing the arrow key through frames.
Changed the image speed of all frames from 100 to 500 to test, and now it doesn’t skip frames.
300 still seems rather stable, but anything 250 or below will start skipping frames when playing back the animation.
Unfortunately, 300 is slow as molasses for a walking animation. :stuck_out_tongue:


#8

It looks like this problem depends on some factor (maybe screen size, sprite size, number of layers, etc.). On my Mac, the problem is visible only when the frame duration is too short (e.g. 10 milliseconds per frame), but 250ms is something to worry about.

Would you like to share the specifications of the screen (resolution, if it’s retina, etc.) and what kind of sprites (size of the sprite, number of layers, how much is visible in the sprite)? What Screen Scaling and UI Scaling are you using (options in Edit > Preferences > General)?

17


#9

shure! in my case:

  • screen resolution 1920x1080
  • default image size 320x240 - indexed colors atm
  • i’m not using layers
  • settings see below

just opening aseprite with these settings, drawing ‘1’ on first frame, duplicating it two times (alt+D) and changing last two frames into ‘2’ and ‘3’ already exhibit the problem… (most minimal way to recreate it)


#10

Ok, I just had this weird shit happen to me too, and when I checked the Frame rate, it had become1 !!!
Once I changed it to 100 the animation ran properly.

This is a bug I think, because I obviously did not set the rate to 1.

(Using version 1.2.6 -x64, Win10)


#11

Hey there, can you people give a try to animation playback hiding the timeline? (pressing the Tab key you can hide/show the Timeline). And see how the performance change when the Timeline is hidden.


#12

One extra trick you can try, is configuring the app to be executed in “low resolution” (non-Retina): http://osxdaily.com/2016/04/16/improve-performance-games-mac-retina-display-trick/


#13

For me this bug is quite random and can even occur when opening someone else’s gif in Aseprite.
But if it happens again I will try hiding the timeline, although I don’t see how that will help if (as in my case) it’s the frame rate of 1 that is the problem.

(Windows 10, v1.2.6)


#14

Yeah wolliel, your case looks like a bug. Some command is setting the frame duration to 1. I’ll try to find the source of this problem too.


#15

i’m not running retina (i’m at 1080p, don’t even have option to set low resolution), hiding timeline doesn’t help either. dunno but to me my case seems like a bug too :confused: @dacap did you test with OSX 10.9? can we trash preferences? meanwhile i tried every version of aseprite avail on steam and they all scramble the animation…


#16

Actually I’m not able to test Aseprite on OS X 10.9 because I don’t have another Mac just to give a try :cry: I’ll see what I can do about it, it’s a high priority issue.

Check this.


#17

switching to fullscreen (using f key) fixes the problem! (i didn’t trash the preferences yet)
edit: playback timing also seems different switching fullscreen on/off
edit2: trashing prefs gives same result, scrambled animation (or some random frameskip with 8+ frames). switching fullscreen it seems ok
edit3: timing seems ok, its due frameskip i think. it seems to skip frames instead of randomizing


#18

Is the new v1.2.8 working better on OS X 10.9?


#19

yes this one fixes my problems, thanks dacap!