Aseprite cursor lag

Whenever I use the program in the canvas the cursor lags.

I am on windows 10 64bits

1 Like

Check a possible solution here:

I’ve got a set of 16GB DDR3 RAM sticks with an I7 processor. the software was running just fine a week ago.

This looks like the most important information here. Something changed in your computer? did you update Aseprite? Or you was always using v1.2.4 in both moments? are you editing bigger images/sprites? did you change your monitor?

I have the same problem, but it only happens when I use the digital tablet. Is there a configuration I should do or something similar?

I’ll try to take a look at this issue soon, if it only happens when digital tablet is used, I’ve something on mind to fix that specific problem.

I have the same problem im on a I7 computer and any time i scroll over with the pen i lags really bad but it worked one hour ago and it doesnt lag when im on the eraser tool or eyedroper tool

Hi @Usiah, what version of Aseprite are you using and in what Operating System (Windows, macOS, or Linux)?

You could try disabling the brush preview from Edit > Preferences > Cursors > Brush Preview = None

33

I’m using windows and aseprite v1.2.9 but I fixed it but deleting and redownloading the application

The application referring to aseprite

Having the same issue “yesterday everything was fine, today it lags”. The only difference is that I updated graphics card driver. I tried these options but none of them helped: UI scaling, brush cursor settings set to none, aseprite reinstalling, installing previous version of graphics driver, using portable version of aseprite. No difference whether I’m using mouse or tablet, whether file resolution is 2k or 1pixel - it lags when application window scaled to screen size. Scaling it to 1/4 size of the screen is the only solution. Eyedropper works just fine no matter what.
I’m using:
aseprite ver. 1.2.17
4k monitor
win 10 64b
geforce card

i got laggy cursor today, and noticed that it lags whenever my browser is open. but there are still some windows when it doesn’t.
i will test this with some other browsers, right now im using chrome

For people with monitors with more than 60 Hz.
Edit>Preferences>Cursors
And change your cursor to the simple one.