Grid size for New Documents not applied

Since the latest update (v1.2.16.2) I have been having an issue with my Grid Settings, namely that it doesn’t apply my default gridsize settings for new documents.

This seems to be very similar to this bug report but since it isn’t the exact issue, I have decided to open a separate bug report.

I always work with a 64x64 grid in my Aseprite document, but since the last update my new documents all have a default 16x16 grid. I checked my settings, and my ‘Grid for New Documents’ showed a width & height of 64x64, as per usual. It seems this setting isn’t applied to my new documents, even though other settings, such as visibility & line colour are applied.

Platform: Windows 10
Aseprite: v1.2.16.2-x64 Steam Version


  1. Open Preferences > Grid & open the ‘Grid For New Documents’ dropdown.
  2. (Check Visible Grid &) set the Width to 64 x 64
  3. Apply & OK the settings
  4. Create a new file.
  5. The new document will have the default 16x16 grid.

Hi @Arecher, we’re working on a fix for these bugs related to preferences to be released next week (maybe this Monday).


Perfect! Thanks for all the effort! :hugs:

1 Like

Today we’ve released v1.2.16.3, this bug should be fixed :pray:


Can confirm the bug is fixed on my end! Thanks once again! :pray: