How to disable hue shifter updated to the saturation/value of selected color

On the left side of the screen in the color selection part, the hue slider at the bottom is updating to the value and saturation of the selected color. It didn’t do this before today, and I want know how to fix this its quite annoying


mate, im sorry to tell you but what you were experiencing is most likely a bug, updating to the select color values is the normal thing to happen.

I’d love to see an option to lock the hue bar to full saturation and only update the other bars. At low saturations, the hue bar gets really hard to read.

FWIW, that’s how it works in Photoshop. Maybe OP is remembering the behaviour from there or some other image editor. I don’t know how it was in Aseprite in the past, I’ve been using the same palette for years ._.

This is a 1.3 exclusive thing though no one I know have experienced it, and it only occurs on the 1.3beta version

Exactly, it’s terrible especially at brighter or darker colors, when I can’t quite tell what color I’m selecting if the bar is almost white/black


Yeah, idk if it works for you but switching to aseprite version 1.2.9 64x made it consistant 100 saturation

Not sure if that’s an option for me because I need the tilemap feature in the beta :confused:

odd behaviour with the colour picker :: Aseprite General Discussion (

Check this one?(didn’t test it, I headed back to 1.2.9)

I tried this. It didn’t help, even after restarting Aseprite.

Hi there, the behavior was changed but I wasn’t sure if that would be a good idea (this change wasn’t included in the previous version). I’m going to roll it back (as there is another critical bug to fix in the last release).

1 Like

I’m going to try to summarize and clarify:

I think people are mostly talking about the hue bar at the bottom of the tint/shade/tone picker. There are a few posts across Steam and social media platforms, though, and without a picture it’s not always obvious.


If there were changes to spectrum, for whatever reason, I haven’t seen as many reports.

In earlier releases, shader-based color pickers had a red-gray problem. See this thread. Hue is undefined when saturation is zero, but throwing exceptions is frowned upon. The hue becomes zero instead. Gray is red (or whatever hue is at zero in the color model).

The shader toggle workaround relied on old code being inconsistent with newer shader code. As the two were made more consistent in subsequent releases, the workaround stopped working.

As far as I know, there is still a problem with discrete normal maps. The shader toggle workaround still works in this case.

Depending on whether someone is using the stable version, the beta version or a version built from Github source code, the timeline for these changes will vary.


Yesterday it was problematic for me to finish a gig that I had with this. What I did that solved this problem was changing to the version v.1.2.25

The new version is already available (v1.2.38 and v1.3-beta19). The only issue is that we’re having problems updating files in Humble Bundle since yesterday because they have a bug that isn’t allowing us to update files. So we’re not making any announcement until that is fixed from their side.

1 Like

It is fixed! Thank you for your hard work


I agree! I had the same situation in yesterday’s v1.2.37 update for steam. When I asked around my friends, I got the response that it always does. Maybe I’ve been using a bug feature before, but I really like it. Thanks to the developers for bringing this feature back in v1.2.38. :yum:

1 Like