Script folder path "cannot open no such file or directory"

Hello, i’m a beginner with aseprite and i spend many hours trying to resolve this issue, a friend help and it seem to work fine on his computer…
GitHub - behreajj/AsepriteAddons: Lua scripts for Aseprite add-ons. i download those who seem dope, followed the steps like other .lua for aseprite and as i said work fine on my friend side and i even tried it on my gf pc and work nicely without path problem…

can’t figure out why, i used dofile(“/support/aseutilities.lua”) for exemple and its not working for me.

i’m a noob in that kind of stuff so if anyone can dumb it down for me would be nice ^^"

Hi @leoli6,

Thanks for giving these addon scripts a try. Did you click on the green code button and download all the scripts as a zip file or did you pick and choose some scripts?


In Aseprite, when you go to the top menu bar File > Scripts > Open Scripts Folder and a system browser opens up, do you see the same folder setup that you see in the zip you downloaded (specifically, folders called dialogs and support)?

Dialog scripts rely upon and call the code for scripts in support – that’s what dofile is about.

Edit: This is how the original path looked, so how does the new path match up with the folder structure in your scripts folder? .. goes up a directory.


Hi jeremy, thank you for the quick response ^^
i did everything by the book multiple times, the zip, the command-dialog and support folders correctly put in the script folder of aseprite, i tried clean reinstall different path naming like changing variables as that guy described but it didn’t fix my problem.

adding a local var at the top to get the Appdata folder and then build the rest of the path:

local AsepriteScriptsFolder	= os.getenv('APPDATA') .. "/Aseprite/scripts/"

and then added that to my file call:

dofile( AsepriteScriptsFolder .. 'MyScript.lua')

still got these messages :

my folders paths :

C:\Program Files (x86)\Steam\steamapps\common\Aseprite

Hi @leoli6,

Not sure, but I’m wondering if this has to do with the é in the user name portion of your path. If that is the issue, I don’t have an immediate fix. Here is an example of the kind of thread where I’d start looking for how to address it, though:

I wrote the stuff below before I noticed the file path in your new post. You might not find the example useful anymore, but I’ll include it anyway.


Suppose that in my scripts folder, I have a folder called example.

These are my scripts:


print("Calling the script baz in the example folder")



print("Calling the script foo.")



print("Calling the script bar in the subdir folder")

This last script, bar, is located in the sub-folder called “subdir.”

When foo.lua calls dofile, it refers to a lua file in a child directory. When bar.lua calls dofile, it refers to a lua file in a parent directory.

When I click on File > Scripts > example > foo, I get this console:


Do you get the same result when you recreate this example?

1 Like

it was this man ! u made my day ^^ i just had to create a new user account without that freaking “é” and now it work like intended :saluting_face:

ty a lot jeremy :smiley:

1 Like