Error Reading Header


#1

I tried to load my .aseprite file from yesterday and i get prompted with an error message, although this was working perfectly last night. Any ideas? this has happened to me twice now and now i have lost my hours of work.


#2

Please send me your .aseprite file to support@aseprite.org


#3

Done. Just sent the broken file :slight_smile:


#4

Sorry @BITbOY I’ve just saw your file and it’s full of null bytes. Other people on Windows 10 experienced this issue too with a possible solution. Where you saving the file in a USB driver? or your personal disk? could you please do a check disk?

Anyway at this moment the file cannot be recovered. I’m thinking for the future some possibles ways to avoid this. For example: 1) reopen the file to validate that it was correctly saved, 2) don’t destroy the sessions data when the program is closed so we can recover old sprites in these special cases.


#5

im saving the files to my personal disk, the C drive. It may be me not shutting my computer down correctly. Thanks for the advice, ill be more cautious in the future.


#6

Hi, I’m using a Surface Pro Book 4 and recently it blue screened (well the Windows 10 version of a blue screen anyway) while I was working on a file. I received the “error in header” message when attempting to reopen the file after the forced reboot. The file is being saved locally - is there anything I can do to try to fix this on my side? I’ve sent the error log - I’m on version 1.2.3


#7

Hi @bit, did you send me an email to support@aseprite.org? We might be able to restore the original sprite if you send me your sessions file. Check the Data Recovery article in the docs.