My aseprite file is empty


#1

Hello, i opened today aseprite file from 28.07.2018, and it turn out to be completely blanck. I mean there were some layers with correct names, but there were nothing there, not even 1 pixel. I tried to hide, unhide, checked opacity and nothing worked. I changed size of canvas because i thought that it may be moved out of my view but it wasn’t. Then i started selecting pixels on the layers but nothing happened. I thought that this file is broken so i checked the one on my portable drive(from the same date) but it is all the same. Besides of that some massive groups of layers just disappeard, whitch is impossible because i saved them by overwriteing the previous version of the file, and even without this in the previous file there were many more layers. I also started to paint on those layers that should be full of elements and it worked(so there can’t be any opacity problems). What’s more weird the file has over 17 mb without a single visible pixel… Please help me, it is over 40 h of my work wasted just like that… I don’t know what happend because i didn’t opened this file over a week and now i would have to begin from scratch…
I use steam/windows version of Aseprite, so it’s updated to newest version right now.


#2

Hi @khado, are you on Windows? can you send me your file to support@aseprite.org? I can check the content and see if I can recover it. It sounds like this issue File full of null bytes but I hope we can recover the file.


#3

Yes, i work on windows, i will send You my file right a way.


#4

Hi @khado, I’ve received your file. It’s possible to recover the data inside it, but it looks like you have reached an internal limit that Aseprite cannot handle: the number of layers. You have way too many layers and cels (41690 layers and 31117 cels).

Internally, in the .aseprite format, each frame has “chunks”, a layer is a chunk, a cel is a chunk, etc., and a frame cannot have more than 65535 chunks (so 41690+31117 is too much for the file format to handle). I’ve never thought about this case (how can you handle soo many layers :sweat_smile:).

I’ll try to send you back to your email your file splitted in several other files or frames.


#5

I’m sending you a “fixed” version of the file. I’ll take note about this bug for v1.2.10, in the future it should be possible to have this kind of files saved correctly.


#6

Thank you very much! It’s a very, very good information, i will remember what you wrote above and try to be careful in that case in the future. I appreciate all work and effort that you put in solving this issue ;]


#7

You’re welcome! and thanks for reporting this bug!